Microsoft Azure Outage affecting all Lodasoft Services

Incident Report for Lodasoft

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 17:43 PDT

Update

Microsoft has issued a statement indicating Azure services will be fully operational at 5:40PM PST.

https://azure.status.microsoft/en-us/status

Lodasoft will continue to monitor the situation and provide any additional updates as we have them.
Posted Oct 29, 2025 - 16:53 PDT

Update

Microsoft has issued a statement indicating Azure services will be fully operational at 4:20PM PST.

https://azure.status.microsoft/en-us/status

Lodasoft will continue to monitor the situation and provide any additional updates as we have them.
Posted Oct 29, 2025 - 15:08 PDT

Update

Lodasoft systems and services are starting to become available as Microsoft works on mitigating the outage. We will continue to monitor the progress and provide updates as we have them.
Posted Oct 29, 2025 - 13:32 PDT

Monitoring

Lodasoft systems and services are impacted by a widespread outage within our third-party provider Microsoft Azure.
Our team will continue to monitor the situation and provide updates as they become available.

https://downdetector.com/status/windows-azure/
https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 08:57 PDT
This incident affected: Third-Party Services.