Updates have been made to address system latency and overall slowness. Our team is actively monitoring throughout the rest of the day (3/27).
Posted Mar 27, 2025 - 08:38 PDT
Update
Continued intermittent slowness expected. On-going maintenance for the remainder of 3/26.
Next expected update: 8:00AM PST
Posted Mar 26, 2025 - 19:39 PDT
Update
Continued intermittent slowness expected. On-going maintenance for the remainder of 3/26.
Next expected update: 6:00PM PST
Posted Mar 26, 2025 - 13:42 PDT
Investigating
Users may experience system latency and overall slowness today. Our team is actively working toward a resolution and will provide updates as we have them.
Next expected update: 12PM PST
Posted Mar 26, 2025 - 08:25 PDT
This incident affected: API (Lodasoft - Core API, Lodasoft - Public API) and Frontend Applications (Lodasoft - Borrower Portal, Lodasoft - Admin Portal, Lodasoft - Agent Portal).