Admin Portal - Intermittent Slowness/Timeouts

Incident Report for Lodasoft

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 20:41 PDT

Monitoring

A fix has been implemented by our development team.

Please press ctrl+shift+r on your keyboard to refresh if you are still experiencing issues.
Our team will continue to monitor system performance throughout the day.
Posted Jul 21, 2025 - 13:21 PDT

Investigating

Our development team is aware and looking into reports of intermittent slowness and timeouts within the Lodasoft Admin portal.
Posted Jul 21, 2025 - 12:13 PDT
This incident affected: Frontend Applications (Lodasoft - Admin Portal).