The fix has been implemented. All Lodasoft applications and services have been restored and should be functioning as expected. We will continue to monitor and provide updates if necessary.
Posted Mar 23, 2026 - 13:42 PDT
Update
Lodasoft will be temporarily brough offline as our team works on fixing this issue. Downtime should be less than 15 minutes.
Posted Mar 23, 2026 - 13:34 PDT
Investigating
We are investigating reports of continued slowness and login issues. Our team is actively working on it, and we expect things to return to normal very shortly.
Posted Mar 23, 2026 - 13:08 PDT
Monitoring
Our team has implemented a fix for the system slowness/timeouts. We will continue to monitor over the next few hours to ensure the system is operating at expected speeds.
Posted Mar 23, 2026 - 08:28 PDT
Update
We are continuing to investigate this issue.
Posted Mar 23, 2026 - 07:40 PDT
Investigating
We have received multiple reports of system slowness/timeouts affecting both the Lodasoft Admin portal and Disclosures. Our team is actively working toward a resolution.
Posted Mar 23, 2026 - 07:39 PDT
This incident affected: Frontend Applications (Lodasoft - Admin Portal).